Home 數位生活 資訊安全 你知道你用的wordpre...

你知道你用的wordpress外掛和模版都有安全性漏洞嗎?(plugins and themes Security Vulnerability)

126
0

wpid-PastedGraphic3-2015-04-24-06-07.png
只要你是使用wordpress的人一定要看,因為你知道你的wp網站可能正陷入安全性及漏洞而被駭的重大危機嗎?
當然,在傑克老師知道這個訊息以後,已在第一時間先更新外掛和模版了,接著就是這篇分享文了。
起因是因為大量的濫用add_query_arg() 和 remove_query_arg()功能,會產生Cross-site Scripting (XSS)的漏洞。
根據國外 sucuri 網站公佈,受影響的外掛包括:

看到上面的列表,有沒有嚇到(有些可能還沒有列出來),包括Jetpet, wordpress seo, all in one seo,….是不是都是我們常在用的外掛呢?那怎麼辨呢?
沒關係,該網站告訴你可以怎麼檢查?有2種方法:

  1. 安裝sucuri提供的wordpress 檢查外掛-sucuri-scanner
  2. 使用sucuri提供的免費的線上網站安全性及惡意軟件檢查工具(Free Website Malware and Security Scanner)

wpid-PastedGraphic2-2015-04-24-06-07.png

幫你的wordpress徹底檢查一下,那麼檢查完以後呢?
請馬上更新你的外掛和模版(plugins and themes),當然最好是連wordpress本身也升級到最新版,也可以防堵漏洞。
還可以安裝一下wordpress 有關Firewall的外掛

ps.更新多多少少會有風險,所以更新前,請記得先備份喔!壞了可不負責。
資料來源:https://blog.sucuri.net/2015/04/security-advisory-xss-vulnerability-affecting-multiple-wordpress-plugins.html

你知道你用的wordpress外掛和模版都有安全性漏洞嗎?(plugins and themes Security Vulnerability)
喜歡這篇文章嗎?

發表迴響